Sorry, we don't support your browser.  Install a modern browser

Security: Add OTP 2FA (Google Auth) field for OpenVPN UI#29

J

OpenVPN UI is not OTP (Google Authentication or whatever) compliance because it doesnt ask for OTP code. It’s about “static-challenge” parameter in ovpn file.

If you want to use OpenVPN in security way (OTP) you need to put a wrapper somewhere and exec it from terminal, which is not a user friendly way, or modify OpenVPN for concatenating passsword+OTP, which is not supported in OpenVPN enterprise appliance (OpenVPN AS).

Regards.

10 days ago
P
Changed the status to
In Discussion
6 days ago